Author Topic: Cant get bot to connect. Using Ubuntu Linux.  (Read 2266 times)

0 Members and 1 Guest are viewing this topic.

Offline deusexm1

  • Newbie
  • *
  • Posts: 2
    • View Profile
Cant get bot to connect. Using Ubuntu Linux.
« on: September 10, 2009, 01:33:17 PM »
[22:52:50.459] NOTICE: Bot 'test' has been started.
[22:53:02.517] DEBUG: Entering disconnect()
[22:53:02.526] DEBUG: Entering connect()
[22:53:02.541] CRITICAL: [BNET] Unable to connect due to exception: exceptions.InvalidVersion: Game not found - warcraft iii: tft
[22:53:41.331] DEBUG: Entering disconnect()
[22:53:41.336] DEBUG: Entering connect()
[22:53:41.374] INFO: [BNLS] Server set to alendar.no-ip.org
[22:53:41.443] INFO: [BNET] Looking up europe.battle.net..
[22:53:41.501] INFO: [BNET] Got 8 addresses. Using: europe.battle.net/213.248.106.204
[22:53:41.502] INFO: [BNET] Connecting..
[22:53:41.711] INFO: [BNET] Connected to /213.248.106.204:6112
[22:53:41.741] INFO: [BNLS] Server set to alendar.no-ip.org
[22:53:41.751] INFO: [BNET] Switched to binary chat protocol.
[22:53:42.010] INFO: [BNET] Authorization info sent, waiting for reply.
[22:53:42.024] DEBUG: [BNET] PacketThread entering receive loop.
[22:53:42.113] DEBUG: [BNET] Logon type: 0
[22:53:42.115] DEBUG: [BNET] Server token: d282882d
[22:53:42.116] DEBUG: [BNET] UDP Value: 4578890
[22:53:42.118] DEBUG: [BNET] MPQ Time: Mon Mar 05 16:48:26 EST 2007
[22:53:42.119] DEBUG: [BNET] Version Check MPQ: lockdown-IX86-17.mpq
[22:53:42.257] DEBUG: [BNET] Client token: 0x1c2c99a
[22:53:42.264] DEBUG: [BNET] Version Hash: 0x1100101
[22:53:42.265] DEBUG: [BNET] Checksum: 0x57032847
[22:53:42.274] DEBUG: [BNET] CDKey owner: Auksinis
[22:53:42.276] INFO: [BNET] CDKey and Version check sent.
[22:53:42.385] Bot tried to use an invalid cdkey.
[22:53:42.402] exceptions.InvalidCDKey: [BNET] Wrong product value for your CD Key
[22:53:42.405] Login.getLogin(Login.java:187)
[22:53:42.416] PluginMain.processedPacket(PluginMain.java:324)
[22:53:42.446] pluginmanagers.PluginRegistration.processedIncomingPacket(PluginRegistration.java:722)
[22:53:42.452] bot.PacketThread.run(PacketThread.java:178)
[22:55:48.478] DEBUG: Entering disconnect()
[22:55:48.483] DEBUG: Entering connect()
[22:55:48.495] INFO: [BNLS] Server set to alendar.no-ip.org
[22:55:48.509] INFO: [BNET] Looking up useast.battle.net..
[22:55:48.529] INFO: [BNET] Got 12 addresses. Using: useast.battle.net/63.240.202.131
[22:55:48.563] INFO: [BNET] Connecting..
[22:55:48.668] INFO: [BNET] Connected to /63.240.202.131:6112
[22:55:48.703] INFO: [BNLS] Server set to alendar.no-ip.org
[22:55:48.717] INFO: [BNET] Switched to binary chat protocol.
[22:55:48.961] INFO: [BNET] Authorization info sent, waiting for reply.
[22:55:48.984] DEBUG: [BNET] PacketThread entering receive loop.
[22:55:48.988] DEBUG: [BNET] Logon type: 0
[22:55:49.001] DEBUG: [BNET] Server token: a36a1a2
[22:55:49.050] DEBUG: [BNET] UDP Value: 3528994
[22:55:49.053] DEBUG: [BNET] MPQ Time: Mon Mar 05 16:48:26 EST 2007
[22:55:49.056] DEBUG: [BNET] Version Check MPQ: lockdown-IX86-19.mpq
[22:55:49.233] DEBUG: [BNET] Client token: 0x4c8a5769
[22:55:49.253] DEBUG: [BNET] Version Hash: 0x1100101
[22:55:49.257] DEBUG: [BNET] Checksum: 0xdf621739
[22:55:49.260] DEBUG: [BNET] CDKey owner: Auksinis
[22:55:49.272] INFO: [BNET] CDKey and Version check sent.
[22:55:49.302] Bot tried to use an invalid cdkey.
[22:55:49.309] exceptions.InvalidCDKey: [BNET] Wrong product value for your CD Key
[22:55:49.311] Login.getLogin(Login.java:187)
[22:55:49.314] PluginMain.processedPacket(PluginMain.java:324)
[22:55:49.317] pluginmanagers.PluginRegistration.processedIncomingPacket(PluginRegistration.java:722)
[22:55:49.320] bot.PacketThread.run(PacketThread.java:178
« Last Edit: September 10, 2009, 10:56:59 PM by deusexm1 »

Offline iago

  • Leader
  • Administrator
  • Hero Member
  • *****
  • Posts: 17928
  • Fnord.
    • View Profile
    • SkullSecurity
Re: Cant get bot to connect. Using Ubuntu Linux.
« Reply #1 on: September 10, 2009, 11:06:25 PM »
Set the game to Starcraft + use RoC key instead of TFT. Fixed !


Offline Joe

  • B&
  • Moderator
  • Hero Member
  • *****
  • Posts: 10320
  • In Soviet Russia, text read you!
    • View Profile
    • William's Blog
Re: Cant get bot to connect. Using Ubuntu Linux.
« Reply #2 on: September 11, 2009, 01:02:47 AM »
[22:53:02.541] CRITICAL: [BNET] Unable to connect due to exception: exceptions.InvalidVersion: Game not found - warcraft iii: tft

In the BnetLogin configuration, select a client from the dropdown list.

[22:55:49.309] exceptions.InvalidCDKey: [BNET] Wrong product value for your CD Key

If this problem persists after selecting a proper client, you typed your CDkey wrong.
I'd personally do as Joe suggests

You might be right about that, Joe.


Offline deusexm1

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cant get bot to connect. Using Ubuntu Linux.
« Reply #3 on: September 11, 2009, 08:12:43 PM »
Lets just concentrate on getting the bot to connect using Warcraft III Roc for now. If i try that here is the output:

Chat window cleared
[20:11:30.015] DEBUG: Entering disconnect()
[20:11:30.018] DEBUG: Entering connect()
[20:11:30.025] INFO: [BNLS] Server set to alendar.no-ip.org
[20:11:30.029] INFO: [BNET] Looking up useast.battle.net..
[20:11:30.045] INFO: [BNET] Got 12 addresses. Using: useast.battle.net/63.240.202.130
[20:11:30.049] INFO: [BNET] Connecting..
[20:11:30.154] INFO: [BNET] Connected to /63.240.202.130:6112
[20:11:30.158] INFO: [BNLS] Server set to alendar.no-ip.org
[20:11:30.162] INFO: [BNET] Switched to binary chat protocol.
[20:11:30.400] INFO: [BNET] Authorization info sent, waiting for reply.
[20:11:30.404] DEBUG: [BNET] PacketThread entering receive loop.
[20:11:30.434] DEBUG: [BNET] Logon type: 2
[20:11:30.465] DEBUG: [BNET] Server token: 81a25e3b
[20:11:30.469] DEBUG: [BNET] UDP Value: 4426093
[20:11:30.506] DEBUG: [BNET] MPQ Time: Mon Mar 05 16:48:30 EST 2007
[20:11:30.509] DEBUG: [BNET] Version Check MPQ: ver-IX86-4.mpq
[20:11:30.518] INFO: [BNET] Server successfully authenticated -- it's Blizzard's
[20:11:30.717] DEBUG: [BNET] Client token: 0x719d5773
[20:11:30.723] DEBUG: [BNET] Version Hash: 0xe6ffffff
[20:11:30.761] DEBUG: [BNET] Checksum: 0xa283c6cb
[20:11:30.764] DEBUG: [BNET] CDKey owner: Auksinis
[20:11:30.767] INFO: [BNET] CDKey and Version check sent.
[20:11:30.794] exceptions.InvalidVersion: [BNET] Invalid game version
[20:11:30.811] Login.getLogin(Login.java:180)
[20:11:30.815] PluginMain.processedPacket(PluginMain.java:324)
[20:11:30.818] pluginmanagers.PluginRegistration.processedIncomingPacket(PluginRegistration.java:722)
[20:11:30.821] bot.PacketThread.run(PacketThread.java:178)

The bot will not connect and it keeps saying i have an invalid game version. What do i do? Also Joe, if i do what you say and choose "Warcraft III: TFT" then i get the error that "Game not found - warcraft iii: tft". I have to change it to something else (lets say SEXP) and then after that I type in "Warcraft iii: tft" exactly like that in order to avoid that error.

Note: If i try to run it using wacraft iii tft, a similar version of this message appears. It states that the game version is invalid and the cd key is incorrect. However, i have 2 sets of cd keys and i have used stealthbot for years before. I know i entered it right, i triple checked. I tried it with the dashes and that did not work, so i just entered one character after another after that and this is the result... Here is the TFT output:

Chat window cleared
[20:16:21.767] DEBUG: Entering disconnect()
[20:16:21.770] DEBUG: Entering connect()
[20:16:21.773] INFO: [BNLS] Server set to alendar.no-ip.org
[20:16:21.777] INFO: [BNET] Looking up useast.battle.net..
[20:16:21.792] INFO: [BNET] Got 12 addresses. Using: useast.battle.net/63.240.202.122
[20:16:21.801] INFO: [BNET] Connecting..
[20:16:21.921] INFO: [BNET] Connected to /63.240.202.122:6112
[20:16:21.930] INFO: [BNLS] Server set to alendar.no-ip.org
[20:16:21.946] INFO: [BNET] Switched to binary chat protocol.
[20:16:22.201] INFO: [BNET] Authorization info sent, waiting for reply.
[20:16:22.210] DEBUG: [BNET] PacketThread entering receive loop.
[20:16:22.228] DEBUG: [BNET] Logon type: 0
[20:16:22.249] DEBUG: [BNET] Server token: 37ef87cd
[20:16:22.252] DEBUG: [BNET] UDP Value: 2707527
[20:16:22.255] DEBUG: [BNET] MPQ Time: Mon Mar 05 16:48:24 EST 2007
[20:16:22.283] DEBUG: [BNET] Version Check MPQ: lockdown-IX86-11.mpq
[20:16:22.505] DEBUG: [BNET] Client token: 0x4ac10d9d
[20:16:22.507] DEBUG: [BNET] Version Hash: 0x1100101
[20:16:22.508] DEBUG: [BNET] Checksum: 0x6ec77580
[20:16:22.509] DEBUG: [BNET] CDKey owner: Auksinis
[20:16:22.525] INFO: [BNET] CDKey and Version check sent.
[20:16:22.543] Bot tried to use an invalid cdkey.
[20:16:22.545] exceptions.InvalidCDKey: [BNET] Wrong product value for your CD Key
[20:16:22.546] Login.getLogin(Login.java:187)
[20:16:22.547] PluginMain.processedPacket(PluginMain.java:324)
[20:16:22.570] pluginmanagers.PluginRegistration.processedIncomingPacket(PluginRegistration.java:722)
[20:16:22.571] bot.PacketThread.run(PacketThread.java:178)


Also i dont know if this is important, but the newest version did not work well for me. I would not be able to load the created bots, and therefore could not even attempt to connect to battle.net. I have installed the sun version of java on this ubuntu machine. iago helped me get it going from a .tgz file. Right now i can use the "test" bot he made, but if i try to make new bots then i also cannot load them. I can only load and edit the bot that was originally in there aka the "test" bot.


« Last Edit: September 11, 2009, 08:26:57 PM by deusexm1 »